Home Forums Support Problem with dependencies

Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
  • #454


    I’m testing your library and it’s wonderful. I’ve put together a client/server example in no time.

    Now I’m trying to implement it in my own software to test if it works in order to license it and use it in our work.

    I’m trying to use this library into a Grasshopper* plugin I’m developing (it’s generated as a DLL with other extension), and it throws this error (translated from spanish error):
    “Could not load file or assembly NetworkCommsDotNet or one of its dependencies. The system cannot find the file specified.”
    The .dll is in the same folder as the plugin, and I use other DLLs in my projects and they don’t fire that error, so I’m thinking about dependencies for NetworkCommsDotNet. Do I have to put another DLL in order to work?
    I’m using .net 4.0 and the Complete DLL. Building from Visual Studio 2010 on Windows 7

    Thanks in advance!

    *Grasshopper is a Rhinoceros 3D extension/tool: http://www.grasshopper3d.com/


    Heya edugargollo,

    Many thanks for your interest in NetworkComms. We’ll definitely help in any way we can.

    To get start it would help to know if this is an error you receive on execution or on compilation?



    Hi, Marc

    The issue happens on execution time. The plugin builds well, and when I debug it that error is shown when the first instruction which uses NetworkComms is going to be called.

    It has happened me only in that plattform. When I use your library in a console application for example, it works well, but I’m unable to make it work into my custom Grasshopper plugin.

    Thank you!


    Ok, so the error is being thrown when it tries to load the assembly.

    It is possible that the error message is caused by a couple of things:

    1. The loading executable may be having issues because of the .net version. I have emailed you a link to a .net2 build which we will be releasing soon as part of version 2.2. We are still testing this version so there may still be bugs.

    2. The loading executable may be struggling with the complete DLL. The complete DLL is actually multiple DLL’s merged into one. This works on every platform we have tested to date but it might be worth trying the individual DLLs as well. The easiest way to do that is to download the source zip bundle and copy all DLLs from the build folder of the ExamplesConsole project into your own. You will then have to add references for each DLL seperately.

    If you try both of those things and still have problems let me know.


    I’ve tried the first option and it worked, so I think the problem was a compatiblity issue with .net4 libraries in Rhinoceros or Grasshopper.

    Thanks again!


    Great to hear. Let us know if you have any further problems.

Viewing 6 posts - 1 through 6 (of 6 total)
  • You must be logged in to reply to this topic.