Home Forums Support Apple 64 bit Apps and Unified Version of NetworkCommsDotNet

  • This topic has 2 replies, 2 voices, and was last updated 7 years ago by Anonymous.
Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
    Posts
  • #3616
    Anonymous
    Inactive

    Hello Support.

    I am using Xamarin to build an IOS app and have been using NetworkCommsDotNet to handle communications back to a server. As from 1 Feb 2015 Apple require all Apps to include 64 bit support and Xamarin have updated Xamarin.Forms to allow this. I have upgraded to the latest Xamarin.Forms but now get an error telling me that NetworkCommsDotNet.dll is referencing Monotouch.dll and can’t be included in the same app with the new version of Xamarin.IOS.dll.

    Is there a build of NetworkCommsDotNet for IOS that can be used with the latest (“Unified”) version of Xamarin.IOS ?

    If I bought an Indie license to get access to the source code would I be able to build a version myself without a reference to Monotouch.dll ?

    I am using V3.0.0.0, would V3.2.0 be any different ? If so how can upgrade to it ? (I have a license for V3.x but can’t see anywhere on the web site where to get the latest version).

    Thank you

    Andrew

    #3617
    Anonymous
    Inactive

    Heya Andrew,

    Yes you should definitely be able to build the assembly using the provided source. If you let me know which email address you used to purchase NetworkComms.Net I will update the purchase to include the latest version.

    Kind regards,
    Marc

    #3626
    Anonymous
    Inactive

    Thanks Marc.

    I have sent my email address to your hello@networkcomms.net email.

    Thanks

    Andrew

Viewing 3 posts - 1 through 3 (of 3 total)
  • You must be logged in to reply to this topic.